interpreting the evidence on an 04 Ford Freestar

Moderators: Nacho, Tom Greenleaf, ACProf, acsource

interpreting the evidence on an 04 Ford Freestar

Postby j1smith2 » Fri Jun 28, 2013 5:51 pm

Need help troubleshooting, as I've hit my limit on how to debug

2004 Freestar with manual dual control front and separate rear control, 3lb 5oz is a full charge

initial comment - I'm used to thinking about systems with a single evaporator. Not really sure how the 2nd evap is plumbed / how it affects these readings. Feel free to educate me


initial condition: passenger side air feels cool (not cold), drivers side is cool sometimes and warm others

Step 1: driver blend door doesn't seem to be following controls reliably - replaced. Symptoms don't change

Step 2: noticed compressor cycling every 15 seconds or so. Checked pressures - were low (sorry, I failed to record specific readings at this point).
    After 1 12oz can R134a:
    lo = 38psi hi = 180 psi
    ambient = 90F, engine idling, doors open, front AC full blast, rear AC off
    compressor quits cycling
    vent temperature = ~70F

Step 3: added 2nd 12oz can:
    lo = 50psi hi = 205 psi
    ambient = 90F, engine idling, doors open, front AC full blast, rear AC off

    kids require help - have to walk off for several hours

Step 4: verify current conditions after distractions:
    vent temp is 61F with an 86F outside ambient

    lo = 37psi hi = 255 psi
    ambient = 86F, engine 1800RPM, doors open, front AC full blast, rear AC off
    big external fan pushing air into the grille

    lo = 42psi hi = 275 psi
    ambient = 86F, engine 1800RPM, doors open, front AC full blast, rear AC full blast
    big external fan pushing air into the grille

Step 5: tentatively add 3rd 12 oz can
    vent temp is 70F with an 86F outside ambient

    lo = 41psi hi = 281 psi
    ambient = 86F, engine 1800RPM, doors open, front AC full blast, rear AC off
    big external fan pushing air into the grille

    lo = 48psi hi = 325 psi
    ambient = 86F, engine 1800RPM, doors open, front AC full blast, rear AC full blast
    big external fan pushing air into the grille
------------------------------------
So at this point, I seem to be overcharged, trying to figure out what's next
Blend door is okay, but maybe heater core valve isn't shutting off?
LO pressure really low enough? Maybe an expansion valve stuck open?
Guess it might be smart to check the rear vent temperature- haven't looked at this :oops:

Suggestions welcome
j1smith2
 
Posts: 1
Joined: Fri Jun 28, 2013 1:39 pm
Favorite Refrigerant: R134a

Return to A/C Questions and Opinions

Who is online

Users browsing this forum: Bing [Bot], Yahoo [Bot] and 5 guests